freebitco.in

Membangun Proxy Server Lusca di Debian dan Optimasi Pada Sisi Mikrotik

Beberapa waktu yang lalu aku sempat mencoba membuat Proxy Server menggunakan Smoothwall dan hasilnya kurang memuaskan karena terbentur di performa Smoothwall.

Kemudian aku mencoba membuat Proxy Server Lusca dengan menggunakan Linux Debian, dan setelah dilihat hasilnya jauh lebih memuaskan baik dari sisi performa maupun ketahanannya.

Bahkan aku menggunakan spesifikasi PC yang sama yaitu P4, HDD 80GB, RAM 1GB …. namun sangat dianjurkan supaya menambah kapasitas baik HDD maupun RAM supaya lebih maksimal.

Nah, ga usah panjang lebar berikut langkah-langkah install Proxy Server Lusca di Linux Debian :

1. Install paket-paket yang dibutuhkan

root@proxy:~# apt-get update
root@proxy:~# apt-get install squid -y
root@proxy:~# apt-get install squid squidclient squid-cgi -y
root@proxy:~# apt-get install gcc -y
root@proxy:~# apt-get install build-essential -y
root@proxy:~# apt-get install sharutils -y
root@proxy:~# apt-get install ccze -y
root@proxy:~# apt-get install libzip-dev -y
root@proxy:~# apt-get install automake1.9 -y

2. Download File Lusca_FMI

root@proxy:~# wget https://app.box.com/s/t9e5yaflrc24h8v09w0m
root@proxy:~# tar xzvf LUSCA_FMI.tar.gz
root@proxy:~# cd LUSCA_FMI

kalau susah download menggunakan CLI, file dapat didownload terlebih dahulu di PC kemudian diupload menggunakan WINSCP.

3. Install dan Compile Lusca_FMI menggunakan perintah :

./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-http-gzip --enable-async-io=24 --with-aufs-threads=24 --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=heap --with-aio --with-dl --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --disable-unlinkd --enable-large-cache-files --with-large-files --enable-err-languages=English --enable-default-err-language=English --with-maxfd=65536 && make && make install

4. Setelah proses install, kemudian buat folder Cache bisa diletakkan di /var/log/ atau /

root@proxy:~# mkdir cache

5. Beri hak user dan group proxy pada folder tersebut

root@proxy:~# chown proxy:proxy /cache

6. Kemudian beri permission :

root@proxy:~# chmod 777 /cache

7. Download file squid.conf dan letakkan pada folder berikut :

root@proxy:~# chown proxy:proxy /etc/squid/squid.conf
root@proxy:~# chmod 777 /etc/squid/squid.conf

8. Download file storeurl.pl dan letakkan pada folder berikut :

root@proxy:~# chown proxy:proxy /etc/squid/storeurl.pl
root@proxy:~# chmod 777 /etc/squid/storeurl.pl

Untuk file squid.conf dan storeurl.pl jangan lupa diberikan user akses, group user proxy dan ubah permissionnya.

9. Jalankan squid dan kemudian restart server :

root@proxy:~# squid start
root@proxy:~# reboot

10. Kemudian test apakah proxy server sudah berjalan dengan benar dengan perintah berikut :

root@proxy:~# tail -f /var/log/squid/access.log

Jika instalasi proxy server berhasil maka akan keluar pesan seperti dibawah ini :

 

atau test menggunakan situs www.lagado.com/proxy-test, hasilnya seperti berikut :

Jika instalasi Proxy Server Lusca sudah selesai dan dinyatakan berhasil maka dapat dihubungkan dengan Mikrotik supaya user dapat menikmati koneksi yang maksimal.

Blokir Pornografi Dengan Proxy Server Lusca :

1. Download file porno.txt dan letakkan pada folder /etc/squid/

2. Buka file squid.conf

3. Cari baris acl dynamic urlpath_regex cgi-bin ?

4. Ketik dibawah baris tersebut acl porn url_regex “/etc/squid/porno.txt

5. Selanjutnya isi http_access deny porn di atas http_access allow manager localhost

6. Kemudian klik Save

7. Kemudian ketik perintah berikut untuk menjalankan squid dengan tambahan konfigurasi yang baru :

squid -k parse
squid -k reconfigure

8. Jika konfigurasi berjalan lancar maka akan muncul seperti screenshot berikut ketika membuka situs porno :

 

Blokir Iklan Pada Website Dengan Proxy Server Lusca :

1. Download file ads.txt dan letakkan pada folder /etc/squid/

2. Buka file squid.conf

3. Cari baris acl dynamic urlpath_regex cgi-bin ?

4. Ketik dibawah baris tersebut acl ads url_regex “/etc/squid/porno.txt

5. Selanjutnya isi http_access deny ads di atas http_access allow manager localhost

6. Kemudian klik Save

7. Kemudian ketik perintah berikut untuk menjalankan squid dengan tambahan konfigurasi yang baru :

squid -k parse
squid -k reconfigure

Peletakkan rule blokir iklan memang hampir sama dengan blokir pornografi hanya variabelnya dirubah menjadi ads yang jelas tidak boleh sama. Dan halaman blokirnya pun sama persis.

Berikut rule pada Mikrotik supaya Traffik Proxy Server Lusca berjalan maksimal pada user :

1. Proxy Hit Rule, supaya trafik dari proxy ke user lebih maksimal

/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=proxy-hit passthrough=no dscp=12

2. Pasang Queue pada Mikrotik untuk menentukan besar traffik dari proxy menuju user, semakin besar semakin cepat akses user terhadap proxy server.

/queue tree add name="A_HIT-Proxy" parent=lan packet-mark=proxy-hit limit-at= queue=default priority=8 max-limit=0 burst-limit=0 
burst-threshold=0 burst-time=0s

3. Supaya user dapat mengakses proxy server tanpa harus memasukkan port, pasang rule berikut pada IP>FIREWALL>NAT :

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.2.20 to-ports=3128 protocol=tcp src-address=!192.168.2.20 src-address-list=LocalNet dst-address-list=!ProxyNet dst-port=80,8080,3128
connection-mark=http-conn

4. HTTP Conn Rules

/ip firewall mangle add chain=prerouting action=mark-connection new-connection-mark=http-conn passthrough=yes protocol=tcp dst-port=80
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=http passthrough=yes connection-mark=http-conn

5. HTTPS Conn Rules

/ip firewall mangle add chain=prerouting action=mark-connection new-connection-mark=https-conn passthrough=yes connection-state=new protocol=tcp dst-port=443
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=https passthrough=no connection-mark=https-conn

6. Rubah MSS

/ip firewall mangle add chain=forward action=change-mss new-mss=1440 tcp-flags=syn protocol=tcp in-interface=public tcp-mss=1441-65535

Dengan rule 1 – 6 diatas proxy server sudah berjalan cukup maksimal pada sisi user, namun rule diatas hanya bisa digunakan hanya untuk 1 ISP saja.

Apabila menggunakan lebih dari 1 ISP dan menggunakan Load Balancing maka perlu ada rule tambahan, seperti berikut :

/ip address
add address=10.0.0.1/8 disabled=no interface=WAN1 network=10.0.0.0
add address=192.168.0.1/24 disabled=no interface=WAN2 network=192.168.0.0
add address=192.168.5.1/24 disabled=no interface=LAN network=192.168.5.0

/ip firewall mangle
add action=mark-connection chain=input disabled=no in-interface=WAN1 new-connection-mark=WAN1_conn passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=WAN2 new-connection-mark=WAN2_conn passthrough=yes
 
add action=mark-connection chain=output comment="Marking Web Proxy Connection for WAN-1" disabled=no dst-port=80 new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=
both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=output comment="Marking Web Proxy Connection for WAN-2" disabled=no dst-port=80 new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=
both-addresses-and-ports:2/1 protocol=tcp
 
add action=mark-connection chain=prerouting comment="Excluding Port 80 from PCC - WAN1" disabled=no dst-address-type=!local dst-port=!80 in-interface=LAN new-connection-mark=WAN1_conn passthrough=yes 
per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting comment="Excluding Port 80 from PCC - WAN2" disabled=no dst-address-type=!local dst-port=!80 in-interface=LAN new-connection-mark=WAN2_conn passthrough=yes 
per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
 
add action=mark-routing chain=prerouting connection-mark=WAN1_conn disabled=no in-interface=LAN new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN2_conn disabled=no in-interface=LAN new-routing-mark=to_WAN2 passthrough=yes
 
add action=mark-routing chain=output connection-mark=WAN1_conn disabled=no new-routing-mark=to_WAN1 passthrough=yes
add action=mark-routing chain=output connection-mark=WAN2_conn disabled=no new-routing-mark=to_WAN2 passthrough=yes
 
add action=accept chain=prerouting disabled=no dst-address=10.0.0.0/8 in-interface=LAN
add action=accept chain=prerouting disabled=no dst-address=192.168.0.0/24 in-interface=LAN
 
/ip firewall nat
add action=masquerade chain=srcnat comment="Masquerade WAN1 Traffic" disabled=no out-interface=WAN1
add action=masquerade chain=srcnat comment="Masquerade WAN2 Traffic" disabled=no out-interface=WAN2
add action=redirect chain=dstnat comment="Redirect port 80 request to Mikrotik Web Proxy" disabled=no dst-port=80 protocol=tcp to-ports=8080
 
/ip route
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=to_WAN1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1 routing-mark=to_WAN2 scope=30 target-scope=10
 
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=10.0.0.1 scope=30 target-scope=10

Dengan rule tambahan ini berarti proxy server sudah bisa berjalan menggunakan Load Balancing menggunakan lebih dari 1 ISP.

Mohon untuk memahami rule2 tersebut sebelum benar2 menerapkan pada Server atau Mikrotik Anda.

Selamat mencoba, dan mohon maaf apabila ada kesalahan ….. karena kesempurnaan hanya milik Allah SWT semata.

sumber: mediacomptech + aacable

Related Search

Tags: #ads #cache #debian #download #ISP #linux #mikrotik #pornografi #server

Anda sedang membaca artikel tentang Membangun Proxy Server Lusca di Debian dan Optimasi Pada Sisi Mikrotik. Silahkan baca artikel Be Log tentang Linux, Mikrotik, Tutorial lainnya. Semoga bermanfaat ...

Setup Storage Path The Dude di RB750G r3
Setup Storage Path The Dude di RB750G r3
The Dude merupakan tool yang cukup penting
Install Teamviewer via Terminal di Ubuntu 18.04 Bionic Beaver
Install Teamviewer via Terminal di Ubuntu 18.04 Bionic Beaver
Aku coba install Teamviewer menggunakan GUI tapi
Cara Membuat Certificates di MikroTik
Cara Membuat Certificates di MikroTik
Certificates yang dibuat pada Mikrotik ini dapat
Setup Raspberry Pi 3 Video Resolution
Setup Raspberry Pi 3 Video Resolution
Raspberry Pi, saat ini bisa menjadi alternatif

Top