Update Dynamic Ip Ke OpenDNS Dengan Mikrotik

In Mikrotik

Situs-situs pornografi, perjudian dan konten negatif lainnya memang masih menjadi popok momok bagi sebagian admin. Karena selain berdampak pada moral user situs-situs seperti itu dapat berdampak buruk pada konektifitas jaringan karena bandwidth dapat tiba-tiba melonjak tajam selain sebagai sumber malware juga.

Oleh karena itu muncul software bloker pornografi namun apakah ini efektif karena adimin harus meng-install pada pc user 1 per 1. Kalau menurutku cara yang paling efektif dan efisien adalah blokir melalui pusat koneksi pada sebuah jaringan yaitu Router.

Ada beberapa alternatif untuk memblokir situs-situs porno dan salah satu yang paling sederhana dan sekali lagi menurutku 😀 adalah menggunakan layanan DNS seperti Nawala dan OpenDNS. Nah, layanan tersebut tinggal disematkan pada router berbasis Mikrotik dan semua situs yang mengandung pornografi dapat terblokir dengan sempurna.

Pada awalnya aku menggunakan DNS Nawala namun ada beberapa situs porno luar yang tidak terfilter oleh Nawala ini, kemudian aku menambahkan OpenDNS. Kendala yang muncul pada saat menggunakan OpenDNS adalah layanan blokir situs porno pada OpenDNS hanya berlaku pada jaringan yang menggunakan IP Statis.

Dan sekali lagi tidak ada masalah yang dapat diselesaikan, bahkan dengan Ip Dinamis kita dapat menggunakan layanan OpenDNS sehingga fitur filter pornografi menjadi lebih maksimal. Ok, ga perlu basa basi berikut langkah-langkahnya :

  • Daftar akun ke OpenDNS.com
  • Daftar akun ke DnsOmatic.com
  • Kemudian masukkan script berikut ke dalam Mikrotik Anda ( sudah ditest pada Mikrotik 5.25 )
# DNSoMatic automatic DNS updates

#--------------- Change Values in this section to match your setup ------------------

# User account info of DNSoMatic

:local maticuser "dnsomatic-username"
:local maticpass "dnsomatic-password"

# Set the hostname or label of network to be updated. This is the part after the double colon (::) on the DNSoMatic services page.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas. 
# Use "all.dnsomatic.com" for the matichost to update all items in dnsomatic with this IP.

:local matichost "hostname1,hostname2"

#------------------------------------------------------------------------------------

# No more changes need

:global previousIP;

:log info "Fetching current IP"

# Get the current public IP using DNS-O-Matic service.
/tool fetch url="http://myip.dnsomatic.com/" mode=http dst-path=mypublicip.txt

# Read the current public IP into the currentIP variable.
:local currentIP [/file get mypublicip.txt contents]

:log info "Fetched current IP as $currentIP"
    
:if ($currentIP != $previousIP) do={
    :log info "DNSoMatic: Update needed"
    :set previousIP $currentIP
    
# The update URL. Note the "3F" is hex for question mark (?). Required since ? is a special character in commands.
    :local url "http://updates.dnsomatic.com/nic/update3Fmyip=$currentIP&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
    :local matichostarray;
    :set matichostarray [:toarray $matichost];
    :foreach host in=$matichostarray do={
        :log info "DNSoMatic: Sending update for $host"
        /tool fetch url=($url . "&hostname=$host") user=$maticuser password=$maticpass mode=http dst-path=("dnsomaticupdate-" . $host . ".txt")
        :log info "DNSoMatic: Host $host updated on DNSoMatic with IP $currentIP"
    }
}  else={
    :log info "DNSoMatic: Previous IP $previousIP and current IP equal, no update need"
}
  • Setelah memasukkan script diatas maka buat juga sebuah scheduler untuk menjalankan script tersebut berdasarkan waktu, misal per 5 menit.
  • Jika pada beberapa kasus update IP tersebut gagal (namun ini jarang sekali terjadi), tapi untuk berjaga-jaga masukkan script berikut untuk merefresh IP yang aktif saat ini.
:global previousIP;
:set previousIP ""

:log info "Cleared previousIP to force DNS-O-Matic update on next run."
  • Kemudian pasang scheduler juga pada script tersebut misal: per 1 jam

 

Catatan: jika setelah script diatas dimasukkan ke dalam Mikrotik namun ip address tidak mau berubah coba untuk merubah settingan ” hostname1,hostname2 ” menjadi ” all.dnsomatic.com ” ( tanpa tanda ” ).

Selamat mencoba …

 

sumber : http://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_DNSoMatic.com_behind_NAT

Related Search

Tags: #mikrotik #nawala #pornografi

Anda sedang membaca artikel tentang Update Dynamic Ip Ke OpenDNS Dengan Mikrotik. Silahkan baca artikel Be Log tentang Mikrotik lainnya. Semoga bermanfaat ...

Bypass Nawala dan Internet Positif di Mikrotik
Bypass Nawala dan Internet Positif di Mikrotik
Mungkin sudah banyak yang bahas, tapi ga
Blokir Share Folder dan Printer Dengan Mikrotik
Blokir Share Folder dan Printer Dengan Mikrotik
Beberapa masalah pada sebuah jaringan di beberapa
Blokir IP Selain IP Client
Blokir IP Selain IP Client
Untuk menghindari user diluar jaringan lokal menggunakan ip
Duck DNS Update Script For Mikrotik
Duck DNS Update Script For Mikrotik #

Top