Block Bruteforce Login Di Mikrotik

In Mikrotik 424 views

Untuk seorang admin router Mikrotik mungkin akan sering melihat akses yang mencoba masuk ke router dari ip address asing. Hal ini apabila dibiarkan maka sangat mengganggu terutama daftar log menjadi banyak, nah oleh karena itu perlu dilakukan ditandakan pencegahan.

Salah satu cara untuk mencegah akses dari ip yang tidak diinginkan cara sederhananya adalah blokir ip tersebut. Berikut script untuk merecord dan mem-blokir ip address yang mencoba mengakses router :

/ip firewall filter
     add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop 
comment="drop ftp brute forcers"
     add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m
     add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" 
address-list=ftp_blacklist address-list-timeout=3h
     add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop 
comment="drop ssh brute forcers" disabled=no
     add chain=input protocol=tcp dst-port=22 connection-state=new 
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist 
address-list-timeout=10d comment="" disabled=no
     add chain=input protocol=tcp dst-port=22 connection-state=new 
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 
address-list-timeout=1m comment="" disabled=no
     add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no
     add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list 
address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no

atau

/ip firewall filter
add action=add-src-to-address-list address-list=SSH_BlackList_1 \
    address-list-timeout=1m chain=input comment=\
    "Drop SSH&TELNET Brute Forcers" connection-state=new dst-port=22-23 \
    protocol=tcp
add action=add-src-to-address-list address-list=SSH_BlackList_2 \
    address-list-timeout=1m chain=input connection-state=new dst-port=\
    22-23 protocol=tcp src-address-list=SSH_BlackList_1
add action=add-src-to-address-list address-list=SSH_BlackList_3 \
    address-list-timeout=1m chain=input connection-state=new dst-port=\
    22-23 protocol=tcp src-address-list=SSH_BlackList_2
add action=add-src-to-address-list address-list=IP_BlackList \
    address-list-timeout=1d chain=input connection-state=new dst-port=\
    22-23 protocol=tcp src-address-list=SSH_BlackList_3
add action=drop chain=input dst-port=22-23 protocol=tcp \
    src-address-list=IP_BlackList

Script diatas akan merecord setiap ip address yang gagal mengakses FTP sebanyak 10x dalam 1 menit dan kemudian merecord ip tersebut serta melakukan drop pada percobaan akses lebih dari 10x.

Sedang untuk ip address yang melakukan brute force ke SSH akan di banned dari router selama 10 hari.

Kalau ada yang salah mohon dimaafkan, dan semoga bermanfaat …..

sumber : Bruteforce_login_prevention

Related Search

Tags: #mikrotik #SSH


MikroTik Deteksi IP Lokal / Public Indihome
MikroTik Deteksi IP Lokal / Public Indihome
Kecepatan koneksi dan harga Indihome menjadi daya
Mikrotik Duckdns.org Update (New Script)
Mikrotik Duckdns.org Update (New Script)
Entah kenapa script untuk update Dynamic IP
Setup Storage Path The Dude di RB750G r3
Setup Storage Path The Dude di RB750G r3
The Dude merupakan tool yang cukup penting
Cara Membuat Certificates di MikroTik
Cara Membuat Certificates di MikroTik
Certificates yang dibuat pada Mikrotik ini dapat

Top