Limit Youtube dan Download File di Mikrotik part 2

In Mikrotik 980 views

Limit Youtube dan Download File di Mikrotik. Tahun lalu aku pernah menulis tentang Limit Youtube dan Limit Download menggunakan layer 7 di Mikrotik, nah pada tutorial kali ini sebenernya ga jauh2 amat bedanya sama yang terdahulu ๐Ÿ˜€ . Trus bedanya dimana ??ย ๐Ÿ˜• coba kita lihat nanti di bawah ini …..

Pada mulanya aku menggunakan Mikrotik versi 3.22 dan rule pada artikel terdahulu memang cukup ampuh untuk me-Limit Youtube dan Download. Tapi setelah mencoba menggunakan RB750 dengan Mikrotik versi 5.9 rule untukย me-Limit Youtube dan Download yang ampuh di versi 3.22 ternyata sudah tidak lagi ~x( ย . Alhasil aku bertanya pada Simbah tentang cara lain yang kompatibel dengan versi yang baru ternyata menemukannya diย forummikrotik.com dan terbukti cukup ampuh.

Berikut langkah-langkhahnya …..

1. Buat script dibawah ini pada Layer 7 Mikrotik, IP >> Firewall >> Layer7 Protocols

/ip firewall layer7-protocol
add comment="" name=youtube regexp="o-o.preferred.pttelkom-|a.youtube.com|b.youtube.com|c.youtube.com|d.youtube.com|e.youtube.c  om|
    f.youtube.com|g.youtube.com|h.youtube.com|i.youtube.com|j.youtube.kom|l.youtube.com"
add comment="" name="Extension " .asf "" regexp=".(asf)"
add comment="" name="Extension " .mov "" regexp=".(mov)"
add comment="" name="Extension " .wmv "" regexp=".(wmv)"
add comment="" name="Extension " .mpg "" regexp=".(mpg)"
add comment="" name="Extension " .mpeg "" regexp=".(mpeg)"
add comment="" name="Extension " .mkv "" regexp=".(mkv)"
add comment="" name="Extension " .avi "" regexp=".(avi)"
add comment="" name="Extension " .flv "" regexp=".(flv)"
add comment="" name="Extension " .wav "" regexp=".(wav)"
add comment="" name="Extension " .mp4 "" regexp=".(mp4)"
add comment="" name="Extension " .rmvb "" regexp=".(rmvb)"
add comment="" name="Extension " .3gp "" regexp=".(3gp)"
add comment="" name="Extension " .mpe "" regexp=".(mpe)"
add comment="" name="Extension " .mp3 "" regexp=".(mp3)"
add comment="" name="Extension " .exe "" regexp=".(exe)"
add comment="" name="Extension " .zip "" regexp=".(zip)"
add comment="" name="Extension " .rar "" regexp=".(rar)"
add comment="" name="Extension " .7z "" regexp=".(7z)"

2. Buat Mangle untuk menangkap packet pada Layer 7 yang sudah dibuat tadi, IP >> Firewall >> Mangle

/ip firewall mangle
add action=mark-packet chain=forward comment="Limit Youtube" disabled=no dst-address-list=!bypass layer7-protocol=youtube 
    new-packet-mark=limit-youtube passthrough=yes
add action=mark-packet chain=forward comment="Limit avi" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .avi "" 
    new-packet-mark=avi-don passthrough=yes
add action=mark-packet chain=forward comment="Limit 3gp" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .3gp "" 
    new-packet-mark=3gp-don passthrough=yes
add action=mark-packet chain=forward comment="Limit asf" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .asf "" 
    new-packet-mark=asf-don passthrough=yes
add action=mark-packet chain=forward comment="Limit mov" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .mov "" 
    new-packet-mark=mov-don passthrough=yes
add action=mark-packet chain=forward comment="Limit wmv" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .wmv "" 
    new-packet-mark=wmv-don passthrough=yes
add action=mark-packet chain=forward comment="Limit mpg" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .mpg "" 
    new-packet-mark=mpg-don passthrough=yes
add action=mark-packet chain=forward comment="Limit mpeg" disabled=no dst-address-list=!bypass layer7-protocol=
    "Extension " .mpeg "" new-packet-mark=mpeg-don passthrough=yes
add action=mark-packet chain=forward comment="Limit mkv" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .mkv "" 
    new-packet-mark=mkv-don passthrough=yes
add action=mark-packet chain=forward comment="Limit flv" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .flv "" 
    new-packet-mark=flv-don passthrough=yes
add action=mark-packet chain=forward comment="Limit wav" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .wav "" 
    new-packet-mark=wav-don passthrough=yes
add action=mark-packet chain=forward comment="Limit mp4" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .mp4 "" 
    new-packet-mark=mp4-don passthrough=yes
add action=mark-packet chain=forward comment="Limit rmvb" disabled=no dst-address-list=!bypass layer7-protocol=
    "Extension " .rmvb "" new-packet-mark=rmvb-don passthrough=yes
add action=mark-packet chain=forward comment="Limit mpe" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .mpe "" 
    new-packet-mark=mpe-don passthrough=yes
add action=mark-packet chain=forward comment="Limit mp3" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .mp3 "" 
    new-packet-mark=mp3-don passthrough=yes
add action=mark-packet chain=forward comment="Limit exe" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .exe "" 
    new-packet-mark=exe-don passthrough=yes
add action=mark-packet chain=forward comment="Limit zip" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .zip "" 
    new-packet-mark=zip-don passthrough=yes
add action=mark-packet chain=forward comment="Limit rar" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .rar "" 
    new-packet-mark=rar-don passthrough=yes
add action=mark-packet chain=forward comment="Limit 7z" disabled=no dst-address-list=!bypass layer7-protocol="Extension " .7z "" 
    new-packet-mark=7z-don passthrough=yes

3. Kemudian, buat Queue Simple untuk me-limit packet Download maupun Youtube yang sudah di tandai di Mangle

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=yutub packet-marks=limit-youtube parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-avi packet-marks=avi-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-3gp packet-marks=3gp-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-asf packet-marks=asf-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-mov packet-marks=mov-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-wmv packet-marks=wmv-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-mpg packet-marks=mgp-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-mpeg packet-marks=mpeg-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-mkv packet-marks=mkv-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-flv packet-marks=flv-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-wav packet-marks=wav-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-mp4 packet-marks=mp4-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-rmvb packet-marks=rmvb-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-mpe packet-marks=mpe-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-mp3 packet-marks=mp3-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-exe packet-marks=exe-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-zip packet-marks=zip-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-rar packet-marks=rar-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all 
    limit-at=0/0 max-limit=32k/32k name=Limit-7z packet-marks=7z-don parent=none priority=8 queue=default-small/default-small 
    total-queue=default-small

sumber : forummikrotik.com

Nah, bedanya apa dengan yang pernah aku tulis terdahulu coba bukaย Limit Youtubeย dan perhatikan script untuk melihat packet Youtube pada Layer 7 diatas.

Kalau dulu menggunakan script

http/(0.9|1.0|1.1)[x09-x0d ][1-5][0-9][0-9][x09-x0d -~]*(content-type: video)

sekarang diganti menjadi

o-o.preferred.pttelkom-|a.youtube.com|b.youtube.com|c.youtube.com|d.youtube.com|e.youtube.com|

update youtube url 21 Maret 2014

^.+(c.youtube.com|googlevideo.com|cdn.dailymotion.com|metacafe.com|mccont.com).*$

dan yang jelas ada perbedaan pada Mangle dan Queue-nya ….. berarti ga ada yang sama ?? ada koq tapi cari aja sendiri ๐Ÿ˜€

Selamat mencoba dan berimprovisasi …..ย  :B

Related Search


Mikrotik Duckdns.org Update (New Script)
Mikrotik Duckdns.org Update (New Script)
Entah kenapa script untuk update Dynamic IP
Setup Storage Path The Dude di RB750G r3
Setup Storage Path The Dude di RB750G r3
The Dude merupakan tool yang cukup penting
Cara Membuat Certificates di MikroTik
Cara Membuat Certificates di MikroTik
Certificates yang dibuat pada Mikrotik ini dapat

Top