Load Balancing 2 ISP Dengan PCC Mikrotik

In Mikrotik 577 views

Memang tidak ada habisnya jika membahas tentang mikrotik, banyak sekali hal baru yang bisa dipelajari dan diimplementasikan dengan software router yang satu ini. Pada kesempatan ini aku mau menulis tentang Load Balancing (LB) 2 ISP dengan menggunakan metode Per Connection Classifier (PCC) di Mikrotik.

Load Balancing sangat dianjurkan jika kita memiliki lebih dari 1 jalur internet (ISP), dengan metode ini pengelolaan koneksi menjadi sangat mudah dan kita tidak menjadi tergantung pada salah satu ISP jika terjadi putus koneksi. Tidak perlu bertele-tele berikut akan aku berikan rule untuk mengaktifkan LB dengan metode PCC.

Langkah-langkahnya :

1. Tentukan ip address Local dan 2 ISP yang dipakai

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2

 

2. Memasukkan rule di Mangle untuk mengaktifkan PCC untuk memanajemen jalur internet dari 2 ISP. Rule ini harus dimasukkan semua dan jangan ada yang terlewat atau PCC tidak dapat berjalan normal.

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1 passthrough=no
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2 passthrough=no

add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1 passthrough=no
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2 passthrough=no

 

3. Kemudian sesuaikan rule pada routes seperti dibawah ini

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping

add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping

 

4. Jangan lupa beri Masquerade pada NAT agar user dapat menjalankan internet

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

 

5. Setting DNS

/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=208.67.222.222,208.67.220.220

 

Sampai dengan langkah ke 5 proses Load Balancing sudah selesai dan dapat digunakan, jangan lupa sesuaikan IP dengan yang digunakan saat ini. Seandainya dari 2 ISP yang digunakan memiliki bandwidth (BW) yang berbeda misal ISP 1 BW: 3mb dan ISP 2 BW: 1mb dan agar jalur internet lebih fokus ke ISP 1 maka rule PCC dapat dirubah menjadi :

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/1 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/2 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

Perhatikan angka 3/0, 3/1 dan 3/2 yang di bold ….. angka 3 tersebut mewakili jumlah sumber koneksi internetnya kalau tetap menggunakan angka 2 maka hanya 2 sumber koneksi yang akan terpakai.

Semoga tutorial mengenai Load Balancing dengan PCC di Mikrotik ini dapat bermanfaat, kurang lebihnya mohon maaf.

source : aacablewiki.mikrotik.com + mikrotik.co.id + FMI

Related Search

Tags: #internet #ISP #Load Balancing #PCC


MikroTik Deteksi IP Lokal / Public Indihome
MikroTik Deteksi IP Lokal / Public Indihome
Kecepatan koneksi dan harga Indihome menjadi daya
Mikrotik Duckdns.org Update (New Script)
Mikrotik Duckdns.org Update (New Script)
Entah kenapa script untuk update Dynamic IP
Setup Storage Path The Dude di RB750G r3
Setup Storage Path The Dude di RB750G r3
The Dude merupakan tool yang cukup penting
Cara Membuat Certificates di MikroTik
Cara Membuat Certificates di MikroTik
Certificates yang dibuat pada Mikrotik ini dapat

Top